Evidence Reports Not Loading

Incident Report for Big Blue Swim School

Resolved

This incident has been resolved.
Posted Mar 23, 2026 - 19:38 CDT

Identified

We're showing the Evidence platform is experiencing issues and their team is working to resolve the outage. This is impacting the embedded evidence dashboards in LessonBuddy. No other LessonBuddy services are impacted.
Posted Mar 23, 2026 - 13:08 CDT
This incident affected: LessonBuddy (Web Application (lessonbuddy.com)).