Staff Schedules Not Loading

Incident Report for Big Blue Swim School

Resolved

This incident has been resolved.
Posted May 15, 2024 - 20:14 CDT

Update

We've implemented a performance improvement to the affected service endpoints and have been monitoring it's performance over weekend and beginning of the week. It appears to have improved. We have another update to make to further improve the process.
Posted May 14, 2024 - 18:02 CDT

Update

We're still showing normal operation and continuing to monitor. We will be keeping this issue open until we're able to push a permanent fix.
Posted May 07, 2024 - 18:17 CDT

Update

We have seen several performance problems with the system responsible for generating the staff schedules over the last few weeks.

We do have an internal work ticket open and have prioritized dev team resources toward a solution.
Posted May 07, 2024 - 14:29 CDT

Monitoring

We've identified the issue and have confirmed the schedules are loading appropriately again.
Posted May 07, 2024 - 13:55 CDT

Investigating

We're investigating reports of the staff schedules not loading
Posted May 07, 2024 - 13:50 CDT
This incident affected: LessonBuddy (API).