Dashboards reporting inflated lessons counts

Incident Report for Big Blue Swim School

Resolved

The issue was identified in an update to the data warehouse pipeline causing duplicate records. This update has been rolled back. This was unrelated to the billing issue.
Posted Apr 03, 2026 - 09:39 CDT

Investigating

We've had several reports of reporting system inflating lesson counts. We are currently investigating.
Posted Apr 03, 2026 - 09:09 CDT
This incident affected: LessonBuddy (API).