We believe the remedies put in place have stabilized the data pipeline as it is operating nominally.
Posted Jun 13, 2025 - 20:42 CDT
Monitoring
Our vendor support has provided potential remedies to resolve the intermittent problem we've been seeing in the pipeline. We're currently working with them to perform maintenance work during off hours to address what they believe is the problem with the replication process.
We have seen a reduction in the frequency of the issue and are continuing to monitor as we complete the recommended work.
Posted Jun 11, 2025 - 12:41 CDT
Investigating
We're re-opening the reporting delay issue. We've opened a case with our cloud provider to help identify the error response we're seeing from their service to our ETL data pipeline vendor.
We've implemented a monitoring alert that is able to identify the symptoms of the issue to allow us to manually intervene and restart the pipeline until we're able to resolve the source issue with our provider.
Due to the manual nature of the intervention, this does appear to be disrupting incremental reporting updates causing some data to become stale for longer than desired times. This may create temporary gaps in reporting in LessonBuddy and Sisense.
We are exploring temporary/alternate solutions to keep data flow active while the primary replication process issue is being resolved.