Reports of LessonBuddy loading slowly, some pages not loading.

Incident Report for Big Blue Swim School

Resolved

This incident has been resolved.
Posted Nov 01, 2025 - 11:07 CDT

Monitoring

We've implemented a patch to resolve the immediate issue and are monitoring services for any issues
Posted Nov 01, 2025 - 10:29 CDT

Investigating

We are currently investigating this issue.
Posted Nov 01, 2025 - 09:39 CDT
This incident affected: LessonBuddy (API).