Instructors Not Showing for Scheduling into Openings

Incident Report for Big Blue Swim School

Postmortem

After auditing the permissions for the Opening Positions configuration, we found that likely it included roles that no longer need this permission and as such have removed the permission from the respective roles to prevent future errors from occurring due to unintended changes. The change has already been made to the system.

Posted May 22, 2024 - 07:26 CDT

Resolved

We've completed the restore of the mapping.
Posted May 20, 2024 - 15:01 CDT

Identified

We've identified that an errant update was made to the allowed positions mapping for scheduling causing some instructors to stop showing in the list for available instructors.

We're currently working to restore this data back to the point in time before the update.
Posted May 20, 2024 - 14:38 CDT
This incident affected: LessonBuddy (API).