Slowness with some actions in LessonBuddy

Incident Report for Big Blue Swim School

Resolved

Load levels are within nominal levels and we are continuing to monitor
Posted Apr 14, 2026 - 15:40 CDT

Investigating

We're currently investigating reports of slowness with some actions in LessonBuddy
Posted Apr 14, 2026 - 15:14 CDT
This incident affected: LessonBuddy (API).