Family Search Issues

Incident Report for Big Blue Swim School

Resolved

After several hours of monitoring, the service continues to be stable.
Posted May 14, 2024 - 18:01 CDT

Monitoring

We've identified the cause and the services have returned to normal status. We're continuing to monitor.
Posted May 14, 2024 - 15:44 CDT

Investigating

We're investigating some reports of family search not returning results
Posted May 14, 2024 - 15:18 CDT
This incident affected: LessonBuddy (API).